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New in Version 2 

Hint: Images and sequences created with FlexMax Version 1 can be opened and edited with Version 2, but not vice versa. 

Colors 

For each object, line color and fill color can be set. 

Hips 

FlexMax has got hips and has thereby become even more flexible. Hips can be moved either 
independently from each other or jointly. 

Lines and Arrows 

Lines can now be running in arbitrary directions. Lines can be straight or curved. Lines can have arrow 
heads on one or both sides. 

Database Export / Import 

You can export any part of your database as a separate database. And you can import other FlexMax 
databases into your database. 

These functions make it easy for FlexMax users to exchange their FlexMax images. 

Better Graphics format for Sequences 

The assembly tool for sequences has been given a new technical basis, to the effect that the 
sequence graphics output has better quality than FlexMax V1.  

Database Entries in Text Fields 

A text field can be linked to a database field. This can be useful if you make heavy use of the 
database schema. 

User Interface Enhancements 

• Start Image can be set 

• Tabs for object and image properties 

• Commands concerning objects collected in new Object menu (Flip, To Front, To Back, …) 

• Simultanious editing of more than one object through multiple selection 

Hint: If you are familiar with Version 1, you may want not to use color or hips in the beginning, to keep the transition as simple 
as possible. In the FlexMax menu, click on View � Settings � Editor, set the color mode to Grayscale and the Start Image 
to Default from Version 1.  

Summary 
FlexMax is: 

• a drawing tool for body postures (“stick figures”) 

• an assembly tool for sequences of body postures 

• a database tool for storing and retrieving body postures and sequences thereof 

• a sample database with postures and sequences from Hatha-Yoga 

The drawing tool starts with a complete body. To draw a specific posture you only change the 
positions of various body parts. With copy and paste you can use the results of your work in your 
documents (e.g. Microsoft Word). And you can store them in the database for later use. 
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The assembly tool enables you to assemble several postures to a sequence and to link them with 
breathing instructions. Again, you can use those sequences in your documents and store them in the 
database. 

The database tool is used to store and retrieve postures and sequences of postures. For easy access  
you can give them a name and other attributes. The set of attributes can be tailored to your needs. 
Either you use the sample database and add your own objects to it, or you create your own database. 

The sample database contains a set of predefined postures and sequences from Hatha Yoga. You 
can either use them directly in your documents, or you can modify and then use them. 

Installing and Starting FlexMax 
If you possess a FlexMax CD, insert it into the CD drive of your computer, and wait a few seconds. 
The installation procedure will start automatically. If for some reason this does not work, open the CD 
with the Windows Explorer and launch the file FlexMaxV2.msi. 

If you have downloaded FlexMax, launch FlexMaxV2.msi from the location where you saved it. 

Follow the instructions of the setup dialogue. 

The setup program adds a FlexMax group to your Start menu, containing these entries: 

• FlexMax. Select this entry to start the drawing tool. 

• Database. By selecting this entry you start the database tool. 

• Help. Select this entry to view the online help for FlexMax. 

In case you don’t have a FlexMax license yet, you may use the program for an evaluation period of 60 
days. This information will appear in a dialogue window whenever you launch FlexMax. Click on Start 
FlexMax in this dialogue window.  

When you buy FlexMax, you receive a 10 digit license key. If you buy FlexMax by download, the 
license key will be sent to you by E-Mail. If you buy FlexMax on CD, you will find the license key either 
at the back cover page of the booklet in the CD jewelcase, or inside the CD in the file keyinfo.txt.   

Click on Enter License Key in the startup dialogue, then write the license key into the text field of the 
window showing up and close the window by clicking on the OK button. From now on the startup 
dialogue will not appear any more, and FlexMax will run without a time limit. 

If you have not entered a license key after 60 days, FlexMax will stop running.  
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The Drawing Tool 

Summary 

 

To start the drawing tool from the Windows Start Menu select Applications – FlexMax – FlexMax. 

The left part of the window shows a stylized body in the default posture. You can select the body parts 
to modify them. Change the direction of the selected body part by dragging the small circle (“handle”) 
at the end of the body part, or by turning the mouse wheel. To turn the body as a whole, turn the 
spine. 

In the right part of the window you can change properties. Which properties are offered for 
modification depends on the body part selected.  

If you click on the background of the image, or on the Image Properties tab, controls for zooming the 
image and for setting its export size appear on the upper right side of the window. The Export View in 
the bottom right part shows what the image will look like in your document. Here, with one mouse 
click, you can put the image into the Windows clipboard from where you can paste it into your 
document.  

Use the commands in the Posture menu to store your image in the database or to fetch one from the 
database.  

Use the commands in the Edit menu to copy parts or all of your image into the clipboard, or to paste a 
FlexMax image from the clipboard into your image. 

Use the commands in the Object menu to flip a figure or to bring an object to the front or to the back. 

The Add menu holds more objects you can use to enrich your image. You can move or change any 
object by mouse dragging. 

The View menu gives you the opportunity to make various features of the FlexMax application visible: 

• Show / hide the image and object properties 

• Show / hide the assembly tool for position sequences 

• Show the database window 

• Show the Settings dialog 
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Editing a Posture 

Modifying Body Parts Directly With the Mouse 

 

If you select the spline, you can change the direction of the whole figure. Make sure the Turn Whole 
Body switch is on, point the mouse cursor to the handle at the top of the spline, press the left mouse 
button and keep it pressed, then move (or “drag”) the mouse. The whole figure will turn round, 
following the movements of the mouse cursor. 

Select some other body part to change its position in the same way: Point to the handle at the end of 
the selected part, press the left mouse button, keep it pressed, and move the mouse. 

If your mouse has a mouse wheel, there is another way to turn a body part: Select it, then turn the 
mouse wheel. 

The form of the mouse cursor indicates in what kind of area the cursor is. Usually the cursor is an 

arrow pointing upwards to the left  . If the cursor touches a body part, it changes to a hand  
indicating that you can select this part here. If it touches the main area of a selected part it, changes to 
a cross  indicating that you can move the whole body by dragging here. If the cursor touches the 
handle of a selected part, it becomes an upward pointing arrow  indicating that you can turn the 
selected part by dragging here. 
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For each body part not only the direction can be changed, but also its length. In addition, the spline 
can be bended, and knees and elbows can be rounded. These and other properties are set in the 
lower right part of the window.  

Setting Properties for the Whole Figure  

Select some body part. In the right part of the window, a frame labeled Figure is shown. 

In the left part of this frame you can set the Line Width for the whole figure. To do this, drag the 
control or enter the desired values into the text fields on top of the control. Line Width can be from 1 
to 5 Pixels.  

To the right there are the Line Color and Fill Color fields. Line Cclor applies to the whole figure, fill 
color applies to the head area. Clicking on one of these fields brings up the color dialog allowing you 
to select or define a color. 

 

 

 

To use one of the base colors, click on it and close the dialog by clicking OK. If you need some other 
color, click on Define Colors, and the dialog will be extended to show the color definition part. 
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Define the color you want by clicking or dragging in the color field and brightness bar, then click on 
Add Color. The newly defined color will be shown in the custom colors list. 

Hint: The list of custom colors is preserved as long as FlexMax is running. You can use it to transfer colors from object to 
object. Whenever the dialog opens, the color of the field from which you opened the dialog will be preset in the color definition 
part of the dialog. You may save it as a custom color by clicking on Add Color.  

In order to use multiple custom colors, you need to move the keyboard focus to the custom color field you want to save the color 
in, before clicking on Add Color. You move the keyboard focus to the custom colors group by pressing the Tab key, and to a 
specific custom color field by pressing the arrow keys. 

You will find further commands to manipulate the figure as a whole in the Object menu. With these 
commands you can flip a figure, or you can place objects in front of others or behind others.  

Setting Properties for Body Parts 

In the right half of the Figure frame you find a list of all body parts. The selection in this list 
corresponds to the selection in the image itself. So you can also select a body part by clicking into this 
list and, if necessary, on the Left or Right button below the list. This way of selecting can be useful if 
direct selection in the image is difficult or if body parts are hidden. 

Below the Figure frame there is another frame labeled after the body part selected. Using the switches 
and controls in this frame you can set the properties of the selected part. Controls can be either 
manipulated directly with the mouse or by entering a numeric value into the associated text box. The 
property Direction can also be set by direct manipulation of the body part (cf.  Modifying Body Parts 
Directly With the Mouse). 

Properties of an Individual Body Part 

• Direction: Direction of the body part, relative to the part to which it is appended, measured in 
minutes on the clock face. E.g., direction 15 for the forearm means a 90

0 
angle between the 

forearm and the upper arm. The direction of the spline is meant in absolute terms. 

 Moving a body part implies moving all the parts appended to it. 

• Length: The length of a body part is measured in per cent of the default length. How to 
change the default lengths, cf. Body Proportions. 

• Hide: Use this check box to make the selected body part invisible. 

• Behind Head: If this check box is on, the selected part is drawn behind the head, in case they 
overlap. 

• Turn Whole Body: If this check box in the Spine frame is activated, not only head and arms 
move together with the spline but also the legs. Thus, by turning the spine you turn the whole 
body. 

• Connect Hips: This check box within the Hips frame connects or disconnects the hips. If they 
are connected, moving one hip will move both hips. 
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Bending the Spine 

Bend the spline using the Bending and Ecxentricity controls, which are shown in the Spine frame. 

• The Bending control determines the extent of the bending. Values can be between -100 and 
100.  

• With the Excentricity control you can shift the bending to the upper or lower spine. Values 
can be between -100 and 100. Positive values indicate that the bending is more in the upper 
spine, negative values indicate that the bending is more in the lower spine. 

Rounding Knees or Elbows 

Knees and elbows can be rounded. The rounding of a knee is a property of the lower leg, the rounding 
of an elbow is a property of the forearm. The controls allow values between 0 and 25. The numeric 
value indicates the rounding radius, measured in per cent of the length of the upper leg or upper arm 
respectively. 

The Head 

For the head, the Excentricity control determines how oval it is. The numeric value indicates the 
relation between height and width of the head in per cent. 

The Hips 

Both hips can be moved either jointly or separately. This is controlled by the Connect Hips switch. 

The Nose 

For the nose there are only three possible directions: 15, 0, and -15. 15 means right, -15 means left, 
and 0 means that the nose is represented by a dot in the middle of the face. 

Adding Other Objects 

Within the Add menu in the drawing tool you can add other objects to a figure. The properties of a 
selected object will be offered for editing in the right part of the window . To move an object first click 
on it, then use the mouse to drag it. Some objects have handles to change their size. 

If you have more than one object in your image, you can select multiple objects. To do this, select 
them one by one with the “Strg” key pressed. You can then move the selected objects jointly, or you 
can set line width, line color and fill color for all of them simultaneously. 

Adding a Figure 

You can have two or more bodies in your drawing, e.g. to show partner postures. 

To add another figure, select Figure from the Add menu. 
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If you want the new figure to be a mirror of an existing one, instead of the standard figure, proceed as 
follows: 

Click on the existing figure and select first Copy and then Paste from the Edit menu. Now click on the 
new figure. Then select the command Flip from the Object menu. 

Adding a Text Line 

Using the Text Line object you can add short comments, such as posture names or breathing 
instructions. 

Select Text Line from the Add menu. Enter your text into the textbox in the Text Line frame. 

 

The Text Line Frame also lets you choose some font properties. The numeric value for the font size 
indicates the font height, measured in per cent of half the longer side of the drawing area with scaling 
set to 100%. The value range is between 4 and 50. 
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You can even bind a text line to a database field. To do so, write the name of the database field with 
brackets into the text line. E. g. if the text line contains “[Name]”, it will display “Virbadrasana” instead. 

Adding Lines and Arrows 

Select Line from the Add menu. You can move or turn a line as needed. To turn a line, select it, then 
move the cursor to a handle at one of the line’s ends, and drag the handle.  

Lines can be straight or curved. You can set the curvature by using the Bending end Excentricity 
controls.  

Lines can have one or two arrow heads. Switch them on and off by clicking on the Arrow Heads 
switches.  

 

Adding Blocks, Circles and Ellipses 

You can use these auxiliary objects to enrich your image. Select Block or Circle from the Add menu. 
Once the object is selected you can change its size and form by dragging the handles. Use the 
controls in the properties area to set line width, line color and fill color. The objects can be drawn 
filled or just as a frame. 
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Controls for the Image as a Whole 

If you click on the Image Properties tab, or if you click into the background of the drawing area, the 
right part of the window offers controls applying to the image as a whole. In addition, the export view is 
shown, that is the view of the image as it will appear in your document. And there is a button which 
allows you to put the image into the Windows clipboard from where you can paste it into your 
document. 

 

 

The Zoom 

Setting the Zoom affects the size of the image in the drawing tool. The Zoom control is used only to 
make editing more comfortable. It has no effect on the size of the image as it appears in your 
document or as it is stored in the database. 
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Export Size 

Use the Export Size control to define the size of the image as it appears in your document, or in the 
database, or in the assembly tool. The numeric value of the export size measures the length of the 
spine in millimeters. The Export view frame shows the image according to the export size set.  

It is possible to change the size of an image after it has been exported to a document, e.g. by 
dragging one of the resize handles showing up when the image is selected in the document. However, 
this changes all the image’s properties, including line width and font size. In contrast, changing the 
export size leaves line width and font size unaltered.  

Managing and Using Posture Images 

Transferring a Posture Image into a Document 

Click on the Image Properties tab, or into the background of the drawing area, to make the settings 
for the image as a whole visible. Then click on the Copy To Clipboard button in the Export View 
frame. 

Or: 

Select Copy All from the Edit menu.  

Both actions lead to the same result: The entire image is being copied into the Windows clipboard, so 
you can paste it into your document. Please consult the documentation of your word processing 
application for details on how to paste images from the clipboard into the document. 

Hint: FlexMax creates its images in the Enhanced Metafile format. Some word processing applications, however, implicitly 
convert this to the weaker Windows Metafile format, which slightly reduces the quality of head and spline display.  

For example, older versions of Microsoft Word (prior to Office XP) do this conversion if you use the Paste command from the 
Edit menu. You can, however, force Word to use the original format by choosing the Paste Contents command and selecting 
Enhanced Metafile in the dialogue window that comes up.   

Storing a Posture Image in the Database 

Select Save As ... in the Posture menu. The following window is displayed. 

 

Into the Name field, enter a name which characterizes the image. 

If your database has an extended scheme of attributes, you can enter values for attributes other than 
the name, which makes it easier for you to find the image later (cf. Editing the Attribute Scheme). 

Click on the Show Database Contents command button if you want to view the database content in 
order to harmonize the new name with existing names. Cf. The Database Tool on how to handle the 
database tool.  

Confirm and close the window by clicking on the OK button. 

Hint: You don’t have to use unique names, you don’t even have to give your postures any names. This is different from the 
Windows file system, where each file has to have a name and file names must be unique within each folder. 

Loading a Posture Image from a Database 

Select Open ... from the Posture menu. The following window opens.  
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Select the posture you want and confirm by clicking on the OK button.  

Or: Double click on the posture image you have selected. 

Cf. Finding Objects in the Database on how to find objects in the database. 

Exporting a Posture Image to a File 

You can store a posture image as a file in the graphics format Enhanced Metafile (.emf). You may 
want to do this in order to send it by e-mail, or to display it on a web page. 

Select Export To File in the Posture menu. In the dialogue window that follows, navigate to a folder, 
and enter a file name. The file name suffix .emf will be appended automatically. 

Importing a Posture Image from a File 

If you have an Enhanced Metafile created by exporting from FlexMax, you can import it into FlexMax. 
Select Import From File … from the Posture menu; then, in the dialogue that opens, navigate to the 
folder containing the file and select it. 

Fetching a Posture Image from a document 

You can transfer a posture image from your document back to the drawing tool for further editing.  

To do this, copy the image from your document to the clipboard. Please consult the documentation of 
your word processing application for details. 

Now switch to the FlexMax drawing tool and select Paste from the Edit menu (or from the Context 
Menu which you open by using the right mouse button in the drawing area). 

Observe that pasting does not remove the previous image from the drawing area. It may, therefore, be 
a good idea to clear the drawing area in advance. 

Customizing the Tool’s Appearance 

You change the size of the drawing tool by dragging an edge or a border of the window. The size of 
the image adapts to the size of the drawing tool.  

To show or hide the properties area, select Properties from the View menu. 

To zoom the image in or out, use the Zoom control. This control is displayed in the properties area, 
after you click on the Image Properties tab (provided the View Properties menu entry is switched 
on). This setting has no effect on the size of the image when you transfer it into a document.  

Settings 

To open the settings window, select Settings from the View menu. 



 14

 

Settings for the Drawing Tool 

Select Color Mode 

If you don’t intend to use FlexMax with colors, you might as well disable the color features altogether, 
by selecting the Grey Scales switch. In this case the color controls of the drawing tool will be replaced 
by the grey scale control, as known from FlexMax Version 1. 

Hint: Please observe that color properties will be lost once you edit an image in grey scale mode. 

Set Start Image 

The start image is the image FlexMax starts up with. You can either click on Current Image, which 
makes the image of the drawing tool (from which you opened the Settings dialog) the sart image. Or 
you click on Default, which makes FlexMax start with the default body.  

By clicking on Default from Version 1 you get the start figure from version 1, which had no colors and 
no hips. Using this start figure, working with Version 2 feels much like working with Version 1. 
Nevertheless, beginning with this start figure, you can use colors, and you can use hips, by clicking on 
them in the list of body parts and setting their length from 0 to 100% (or some other value of your 
choice). 

Export Size for Posture Images 

In this tab you can control the default Export Size, which is assumed whenever FlexMax starts with a 
new image. You can change this setting for each image, and it is being saved along with the image. 

Hit Tolerance for Mouse Click 

When you click on an object, a hit is detected if the click is within a certain range around the object. 
Here you can increase or decrease this range. The default value is 170, which has only relative 
meaning. 

Use Defaults 

Click on this button to fill the fields in this tab with the manufacturer values. 
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Settings for the Figure 

 

Body Proportions 

In this tab you can set the default lengths for the individual body parts. The values entered here are 
used as 100% reference value in the length controls. Human bodies have incredible variety, and the 
values chosen here are a kinde of compromise, resulting from research and experience. Change them 
only if you have good reasons to do so. 

All existing images stay unaltered by any changes of these settings. They are only reflected by a 
corresponding change of percentage in the drawing tool. For example: if you have a posture with 
spine length 100%, and if you change the spine default length from 50 to 60, then in the posture editor 
you will see a spine length of 83 %, the visual length being unaltered. 

The measuring unit for these values is 1/200 of the longer side of the drawing area in the drawing tool 
with zoom=100%. The absolute size of the body is determined by its export size. Export size is the 
length of a 100% spine with default length 50, measured in millimeters.  

Use Defaults 

Click on this button to fill the fields in this tab with the producer values. 

Settings for the Breathing Instructions 

See Settings for the Breathing Instructions in the Assembly Tool part of this document. 

Menu Commands 

Posture 

New 

Deletes the current image and creates a new image using the default figure. 

Open ... 

Opens a dialogue window to select a posture image from the current database. To open objects from 
a different database, cf. Changing the Current Database. 
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Save 

This entry is active only if the current object has been opened from the database. The command 
overwrites the database object with the current image. 

Save As ... 

This command opens a dialogue window which allows you to enter attributes (such as name) to be 
stored with the posture image. The image will then be stored in the database as a new object. 

Export To File … 

This command opens a file browser dialogue allowing you to navigate to a folder and to enter a name 
for the file in which the current posture image shall be stored. The file name suffix .emf for Enhanced 
Metafile is appended automatically. 

Import from File … 

This command opens a file browser dialogue allowing you to navigate to a folder and to select a file in 
the Enhanced Metafile (.emf) format. If this file has been created by exporting from FlexMax, the 
content will be loaded into the drawing tool. 

Exit 

Closes the drawing tool. 

Edit 

Hint: If also the assembly tool for sequences is visible, the Edit menu acts either on the selected object(s) in the position editor 
or in the assemly tool, according to which of them has the focus (click on either of the panels to see how focus changes 
between them).  

The commands of the Edit menu are also available in the context menu (right-mousebutton-menu) of the editor background. 

Undo 

Restores the image to the state before the last change. 

Copy All 

Copies the entire image to the Windows clipboard. The image format ist Enhanced Metafile. 

Cut 

Deletes the selected objects (Figure, Line, Block, …) from the drawing area and puts them as a single 
picture into the Windows clipboard. The image format ist Enhanced Metafile. 

Copy 

Copies the selected objects as a single picture to the Windows clipboard. The image format is 
Enhanced Metafile. 

Paste 

Inserts objects from the Windows clipboard, provided they are Enhanced Metafile images created by 
FlexMax. You can, e.g., copy a FlexMax image from Word into the Windows clipboard and then paste 
it into FlexMax for further editing. 

The Paste command does not clear the drawing area, it just adds an object to what is already there. 

Delete 

Deletes the selected object(s) from the image. Pressing the Del key has the same effect. 
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Object 

To Back 

Places the selected object behind any other objects in the image. 

To Front 

Places the selected object in front of any other objects in the image. 

Hint: In order to place individual body parts before or behind the head, use the Behind Head check box in the frame for the 
body part in question. 

Use This as Template for New Objects 

After you have selected this command, the current object will be used whenever you request a new 
object of this type from the Add menu.  

Use Default Template 

After you have selected this command, the pre-defined template for this type of object will be used if 
you request a new object of this type from the Add menu. 

Flip Vertical 

This command is only available if a figure is selected (or if a figure is the only object in your image). 
Flips the whole figure around its spline. 

Set all body parts to Length 100% 

This command is only available if a figure is selected (or if a figure is the only object in your image). It 
sets all body parts to their default length of 100%.  

Hint: In the Settings dialog, the default lengths for the various body parts can be altered. This has no effect on the appearance 
of individual images, but it alters the length properties of their body parts, which is in percent of the default lengths. Use this 
command if you intend to apply altered default settings to a particular figure. Please be aware that this may yield unexpected 
results if the length properties had been other than 100% bofere the default had been changed.  

Add 

This menu offers to add more objects to your image. 

Figure 

Adds another figure to the image.  

Text Line 

Adds a text line to the image. The text can be entered in the textbox of the Text Line frame. You can 
move the text line by dragging it with the mouse. 

In the Text Line frame you can also set the font properties. 

You may link a text line to a field of your database. Enter the name of a database column, enclosed in 
square brackets. For example, if you enter “[Name]”, the name of the figure, as stored in the database, 
will be displayed in the text field. 

Line 

Adds a line. Use mouse dragging to move it and to change its size and direction. In the Line frame 
you can set line width and line color. With the Bending and Excentricity controls, you can set the 
line’s curvature. Use one or both of the Arrow Head check boxes for arrows. 

Block 

Adds a rectangle. Change its size by dragging its resize handles. In the Block frame you can set line 
width, line color and fill color. Fill color applies only if the Filled switch is on. 
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Circle 

Adds a circle. Change size and form by dragging the circle’s resize handles. In the Circle frame you 
can set line width, line color and fill color. Fill color applies only if the Filled switch is on. 

View 

Properties 

With this command you can show or hide the properties area in the right part of the window. 

Assembly Tool 

With this command you can show or hide the assembly tool for posture sequences. The assembly tool 
is displayed in the same window below the drawing tool. 

Database 

This command opens the database view.  

Settings 

This command opens the Settings dialogue window. 

Help 

Contents 

This command opens the help contents. The help system is viewed with the current Internet Browser. 

About ... 

This command opens a window showing product name and version. 

Context Menu 

To open the context menu click with the right mouse button into the drawing area. The menu contains 
the same commands as the Edit menu. 
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The Assembly Tool 

Summary 

 

To start the assembly tool, first start the drawing tool and then select Assembly Tool from the View 
menu. 

The assembly tool is displayed below the drawing tool. Between the two tools there is a grey line. Drag 
this line with the mouse to change the height of the assembly area. 

The menu bar now contains another menu Sequence with commands similar to those of the Posture 
menu. Using the Sequence menu you can load sequences from the database and save sequences to 
the database.  

The commands in the Edit menu operate on the assembly tool whenever the assembly area is active. 
The active area is indicated by an additional black border line around it.  

The assembly area is a textbox in which you can insert images. Just as in your word processing 
application, you can set the insertion cursor with a mouse click and you can select a text range by 
dragging the mouse over it. To select an image, click on it.  

Hint: For technical reasons, the assembly tool performs a conversion from the Enhanced Metafile format to the weaker Metafile 
format. As a consequence, the display quality for the head and the spline is slightly reduced. If this should be unacceptable in 
certain cases, please transfer posture images directly from the drawing tool into your document, without using the assembly 
tool.  
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Assembling a Sequence 

Adding a Posture Image 

From the Drawing Tool 

A mouse click in the assembly area sets the insertion point to the place where you want the new 
image to be placed.  

Click on the Down Arrow  between the drawing area and the assembly area to copy the image 
from the drawing tool into the sequence. 

From the Database 

Select Database from the View menu. This opens the database in a new window. 

In the database window, use the right mouse button to click on the image wanted and select Copy 
from the context menu. Compare Finding Objects in the Database on how to find an image in the 
database. 

In the assembly tool, set the insertion point to the place where you want the posture to be. Use the 
right mouse button to click in the assembly area and select Paste from the context menu. 

From a Document 

In your document, copy the posture image into the clipboard. Consult the documentation of your word 
processing application for details. 

In the assembly tool, set the insertion point to the place where you want the posture to be. Right-click 
and select Paste from the context menu. 

Changing a Posture Image 

Editing a Posture Image 

In the assembly tool, select the posture image and click on the Up Arrow . This copies the image 
into the drawing tool. If there was an unsaved image in the drawing tool, you will be given an option to 
save it first. 

After you have made the changes to the posture image, select the old posture image in the assembly 

tool and click on the Down arrow . The old posture will then be replaced by the new one. 

Rescaling a Posture Image 

You may want to change the export size of an individual posture image in order to harmonize the 
sequence. Click on the posture image you want to rescale, and select Rescale from the Edit menu or 
from the right-click context menu. A dialogue window allows you to enter the desired size. The export 
size which has been used for the image so far is displayed here for reference. For the interpretation of 
the numeric value cf. Export Size. 

 

Close the window by clicking on the OK button. 

Rescaling a Sequence 

You can rescale the size of all posture images and breathing instructions in one stroke. To do this, 
select Rescale Whole Sequence from the Edit menu or from the right-click context menu. A 
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dialogue window allows you to enter the desired size. The current export size of the images is 
displayed here for reference; if they vary, the variation interval is shown.  

 

Inserting Breathing Instructions 

In its upper right corner, the assembly tool contains a few predefined breathing instructions which you 
can insert between posture images. Set the insertion cursor to the place wanted and click on the 
button showing the breathing instruction you want.  

The size of the breathing insert depends on the Export Size of the current posture in the drawing area. 
To change it, proceed as follows. Make sure that Properties is switched on in the View menu. Now 
click on the Image Properties tab and, in the Picture frame, use the Export Size control to change 
the export size. 

Please refer to Settings for the Breathing Instructions on how to control the other properties of the 
breathing instructions.  

The two rightmost breathing instructions are meant to close a circular sequence with a breathing 
instruction leading from the rightmost image to the first (or some other) image. This type of instruction 
should be inserted after the rightmost image, and it places itself in the next line. 

This type of breathing insert consists of three parts: a cornered line on the right, a text, and a cornered 
arrow pointing up on the left. These parts can be individually positioned by inserting blanks between 
them. 
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Managing and Using Sequences 

Transferring a Sequence Into a Document 

Select the Copy All entry from the Edit menu or from the right-click context menu. This copies your 
entire sequence into the Windows clipboard, so you can paste it into your document. 

Storing a Sequence In the Database 

Select Save As ... from the Sequence menu. The following window opens.  

 

Into the Name field, enter a name which characterizes the sequence. 

If your database has an extended attribute scheme, you can enter other attributes for easy access. (cf. 
Finding Objects in the Database) 

In the first column the first posture image of the sequence is displayed. If you want to have your 
sequence represented by a different posture, click on the image you see. The sequence opens, and 
you can select some other image which will then be displayed in the first column of the database view. 

Close the window by clicking on the OK button. 

Retrieving a Sequence From the Database 

Select Open ... from the Sequence menu. The following window opens up. 

 

Select the sequence you want and close the window by clicking on the OK button. Please refer to 
Finding Objects in the Database on how to find objects in the database. 

Exporting a Sequence To a File 

You can store a sequence in a file with format Rich Text (.rtf). You may want to do this in order to 
send it to a friend by E-Mail. 

Select Export To File from the Sequence menu. In the file browser dialogue, navigate to a folder and 
enter a name for the file. The file name extension .rtf is appended automatically. 
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Importing a Sequence From a File 

You can import a file with format Rich Text (.rtf) into the assembly tool. 

Select Import From File … from the Sequence menu. In the file browser dialogue, navigate to the 
folder containing the file and select the file. 

Customizing the Tool’s Appearance 

You can change the height of the assembly area by dragging the grey line between the drawing area 
and the assembly area. 

Settings 

Open the Settings dialogue window by selecting Settings from the View menu. 

 

Settings for the Breathing Instructions 

This tab has three frames in which you can enter settings for the texts, sizes, and the font used in 
breathing instructions. 

Texts 

Here you enter the text to be used for in and out breath. If you leave this field empty, „In“ and „Out“ will 
be used (or, in the German version, „E“ and „A“). 

Sizes 

The measuring unit used here is the same as in the Drawing Tool tab. 

• Arrow Length 

• Upper Text Offset: Vertical distance between first text and first arrow. Negative values can be 
used. 

• Lower Text Offset: Vertical distance between second arrow and second text. Negative values 
can be used. 

• Arrow Distance: Vertical distance between two arrows. 

• Arrow Top  
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• Height Above Ground Line  

• Width Backward Corner, Height Backward Corner: These settings refer to the two 
rightmost buttons in the breathing inserts button group. Such an insert consists of three parts 
which can be separated by blanks to bring them into the fitting positions: 

(a) a cornered arrow pointing upwards on the left 

(b) a text 

(c) a cornered line on the right 

The setting controls width and height of parts (a) and (c). 

Font 

• Font Name: Click on the arrow to the right of this field to open a list of all fonts installed on 
your computer. Select the one you want. 

• Font Size: This is a relative setting, it refers to the height of the text. 

• Bold: Switch this on to have the text in bold. 

• Italic: Switch this on to have the text in italics. 

Menu Commands 

Sequence 

New 

Deletes the current sequence. 

Open ... 

Opens a dialogue window in which you can select a sequence from the current database. To open 
objects from a different database, cf. Changing the Current Database. 

Save 

This entry is active only if the current sequence has been opened from the database. The command 
overwrites the old database entry with the current sequence. 

Save As ... 

This command opens a dialogue window which allows you to enter attributes (such as name) to be 
stored with the sequence. The sequence will then be stored in the database as a new object. 

Export To File… 

This command opens a file browser dialogue. Navigate to a folder and enter a name for the file to 
store the current content of the assembly tool. The file automatically gets the suffix .rtf and will be in 
Rich Text format. 

Import From File … 

This command opens a file browser dialogue, allowing you to navigate to a folder and select a Rich 
Text formatted file. Its content will be loaded into the assembly tool. 

Edit 

This menu operates on the drawing tool or on the assembly tool, depending on which of them is 
active. The active area is indicated by a black border line. The effects of these commands within the 
context of the assembly tool are analogous to their effects within the drawing tool. 

If the assembly tool is active, the edit menu contains two more commands: 
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Rescale 

Opens a dialogue to enter the new export size for the selected posture image or breathing insert. In 
this dialogue, the old export size is shown for reference. 

Rescale whole sequence 

Opens a dialogue to enter the new export size for all of the posture images and breathing inserts in 
the sequence. In this dialogue, the old export size (or range of export sizes) is shown for reference. 

View 

Settings 

The Breathing tab refers to the breathing inserts in the assembly tool. 

Properties 

The size of a breathing insert is determined by the export size of the posture image currently in the 
drawing tool. In order to change it, the Properties command must be switched on. 

Context Menu 

The context menu opens when you right-click into the assembly window. It is identical with the Edit 
menu for the assembly tool. 

The Database Tool 

Summary 

Start the database tool by selecting Database from the FlexMax group in the Windows Start Menu. 

Or, if the drawing tool is open, select Database from the View menu. 

 

The database tool displays the contents of a database. Using the commands in the File menu you can 
change the database or create a new one. 

Each content line in the database tool displays one object. The Edit menu, or the right-click context 
menu of the content lines, allows you to open an object for editing, to delete an object, or to copy an 
object into the clipboard so you can paste it into your documents. 
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Each column displays one attribute. The header line shows the attribute names, the content lines 
display the attribute values. 

In the selection line you can enter attribute values in order to view a specific selection of objects. Click 
into any of those fields to enter a value. If, for example, you enter the letter “s” into the Name field of 
the selection row, only those objects whose names begin with “S” or “s” will be displayed. 

You can sort by an attribute by clicking on the attribute’s name. If you click on Name, for example, all 
entries will be sorted alphabetically by their names. Click again on Name, and they will be displayed in 
reverse alphabetical order. 

The context menu of the header line displays all attributes available and allows you to select the ones 
that are displayed as columns. You can switch columns or change column widths by mouse dragging 
within the header line.  

Which objects are displayed depends on the content of the selection line. The number of objects 
displayed can be limited using the command Set hit limit in the settings menu. 

The first column displays a preview image of the object. The header field of the first column shows the 
object count. In this field, an entry like 100+ in red color is an indication that a hit limit is active: Even 
though more than 100 objects satisfy the selection criterion only 100 are displayed.  

The Type column shows whether an object is a posture image or a sequence. 

The Settings menu allows you to change the attribute scheme of the database or to configure the hit 
limit. 

You get a restricted view of the database if you select Open from the Position menu of the drawing 
tool (or from the Sequence menu of the assembly tool). This restricted view does not display a menu 
bar or a context menu, and the Type column is always invisible. 

Finding Objects in the Database 

If nothing is entered into the selection line and no hit limit is active, the database tool displays all the 
objects in the active database. Use the scroll bars on the right, or the mouse wheel, to scroll the 
contents up or down. Click on the Name header to sort the objects by name. Clicking again on the 
Name header reverts the sorting order. In the same way you can sort the contents by any other 
attribute. When you are searching for self-created objects the date attributes labeled Created and 
Last Changed may be helpful. To make them visible cf. Customizing Database View. 

If the database is large, you may want to enter a selection criterion in order to reduce the number of 
objects shown. E.g., if you are looking for an object named “Sun Salutation”, enter the letter “s” in the 
Name selection field, and only those objects with first letter “s” will be displayed (the use of small or 
large initial letters is irrelevant in this context). If these are still too many objects enter “su” to further 
reduce the selection. 

Other attributes are used in the same way. If you have entered two selection criteria, only those 
objects will be shown which satisfy both criteria. Some attributes are entered by selecting from a list of 
possible values, such as the Type attribute, which can only have the value Posture or Sequence. 
Select All if you want no restriction for this attribute. 

The Created and Last Changed attributes can only be used for sorting, not for selecting.  

If many objects are displayed, the display can become quite slow. For this reason it may be useful to 
activate a hit limit. To configure the hit limit, select Hit Limit in the Settings menu. In the configuration 
window you can activate or deactivate the hit limit and you can set the numeric value of the limit. 
Observe that the hit count is displayed as a red number followed by a “+” sign if the selection shown 
has been cut off due to the hit limit. 

Using Objects from the Database 

Right-click on the object you want to use. The context menu opens. Select the Copy command. 

Or: Click on the object you want to use. In the Edit menu, select the Copy command. 

This copies the object into the Windows clipboard. From there you can paste it into your document. 
Please consult the documentation of your word processing application for details. Also, observe the 
hint on Transferring a Posture Image into a Document in the Drawing Tool chapter. 
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Editing Objects in the Database 

Editing Attributes 

There are two types of attributes: Free Text attributes and Selection attributes.  

For a Free Text attribute, double-click into the field and enter the desired value with the keyboard. 

For a Selection attribute, double-clicking into the field opens a list from which you can select the 
desired value. If you don’t want to have a value for this attribute, select Not Set. 

Changing the Image Representing a Sequence 

Right-click on the image you want to change and select Select Image to Show here from the context 
menu. The sequence opens, and you can select the image wanted. The sequence will be closed and 
the image replaced. 

Editing an Object 

Right-click on the line you want, and select Open from the context menu. 

Or shorter: Double-click on the image you want. 

The object will be opened in the respective tool window (drawing tool or assembly tool). In this way 
you can have more than one object opened simultaneously in several windows. 

After changing the object, select Save from the Posture or Sequence menu respectively. The object 
in the database will then be updated. 

If you want to keep the original object unchanged, select Save As instead. This opens a dialogue 
which allows you to enter new attribute values. 

Hint: Unlike a folder in the Windows explorer, the database can contain several objects with the same name. Of course it is a 
good idea to differentiate those objects by at least one attribute value. But technically speaking, even that is not necessary. 

Adding an Object 

You add objects to the database by creating them in the drawing tool or assembly tool and using the 
Save As command, cf. Save As ... (Position Menu)  and Save As ... (Sequence Menu). 

Customizing the Database View 

Change the size of the database view by dragging a border or an edge of the window.  

Change column widths by dragging the border lines between columns in the header line.  

Change column order by dragging column headers.  

You can show or hide individual attribute columns. Right-clicking on the header line opens a menu 
which shows all available attributes with a check mark on the visible ones. Click on an attribute to 
reverse its visibility state. 
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Managing Databases 

Changing the Current Database 

Select Change Database in the File menu. In the file browser window, navigate to the desired 
database and click on it. Close the dialogue by clicking on the OK button.  

To return to the default database, select Use Default Database in the File menu.  

Hint: FlexMax-Databases have the suffix .mdb (Microsoft Database). If you try to open a database with this suffix which has not  
been created by FlexMax, an error message will show up. 

Creating a New Database 

Select Create New Database from the File menu. In the file browser dialogue, navigate to the folder 
where you want the new database to be and enter a name for it (the suffix .mdb will be appended 
automatically). 

Customize the database’s attrbitue scheme to your liking, as described below. 

Exporting parts of the database 

Using the Export command you create a new FlexMax database containing the database entries you 
are exporting. The export command has a submenu with three ways to specifiy the set of entries to be 
exported: 

• All Entries 

This leads to creating a copy of the database. 

• Current Selection 

This command is available if the selection line contains information to the effect that not the 
entire database content is currently shown. Only those entries which are shown will be 
exported. 

• Marked Entries 

This command is available if one or more entries are marked by clicking on them. Only the 
marked entries will be exported. Mark multiple entries by clicking on them one by one with the 
Strg key pressed. 

After you have selected one of these commands, a dialog appears in which you can navigate to a 
folder and enter a name for the new database. The database suffix “.mdb” will be added automatically.  

Importing a database 

You can import a FlexMax database (which you may e.g. have received from a different FlexMax user) 
into your database. Your database will then contain all entries of this database, together with your own 
entries. To do this, select Import from the File menu. In the dialog, navigate to the database to be 
imported and select it, then confirm the dialog by clicking OK.  

It may be that the user who created the other database has added columns which are not present in 
your database. If this is so, a message box will prompt you with two choices.  

 

Click Yes to expand your database schema such that the new columns will be present in your 
database. 

Click No to ignore those columns and leave your database schema unaltered. The information 
contained in those columns will not be imported to your database. 
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Click Cancel to abort the import entirely. Your database will stay unaltered. 

If the imported database contains a column with the same name as one of your columns, but with a 
different type, this column cannot be imported. A message box will inform you about this fact. 

If you try to import a database which has not been created with FlexMax, an error message will come 
up. 

Editing the Attribute Scheme 

There are two types of attributes: 

• Free Text attributes. E.g., you could have a “Variant” attribute to distinguish entries having the 
same name. 

• Selection Attributes. E.g., you could have an attribute “Tradition” with values “Iyengar” and 
“Desikachar”. 

Select Edit Attribute Scheme from the Settings menu. The following window is opened. Close it by 
clicking on the Close button, when you are done with editing. 

 

Adding a Free Text attribute 

Click on the New button in the Attribute frame.  

 

In the sub dialogue, enter the attribute’s name.  

Close the sub dialogue by clicking on the OK button. 

The new attribute is listed in the Attributes frame.  

Hint: Attribute names can contain only letters of the English alphabet, numbers, and blanks. 

Adding a Selection attribute 

Click on the New button in the Attribute frame.  

 

In the sub dialogue, enter the name of the attribute. 



 30

Select the Choice option. 

Close the sub dialogue by clicking on the OK button. 

The new attribute is now listed in the Attribute frame. As long as it is selected, the right part of the 
window shows another frame labeled with the new attribute name. 

 

Select the New button in the right-hand frame. 

 

In the sub dialogue, enter a value for the attribute. 

Close the sub dialogue by clicking on the OK button. 

Repeat the last 3 steps for any other values you want to add. 

 

Renaming an attribute 

Click on Rename in the Attribute frame. In the sub dialogue, enter the new name. Close the sub 
dialogue by clicking on the OK button. 

Deleting an attribute 

Click on the Delete button in the Attribute frame.  

Deleting an attribute is possible only if no object in the database has a value for the attribute. 
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Editing Attribute Values 

If, in the Attribute frame, a Selection attribute is selected, the corresponding set of possible values is 
displayed in a frame on the right.  

Beside this frame there are command buttons New, Rename, and Delete. Use them to change the list 
of attribute values. 

Changing the set of attribute values is possible only if no object has a value for this attribute. 

Setting a Hit Limit 

Select Set Hit Limit from the Settings menu to open the following dialogue window. 

 

Here you can switch the hit limit on or off and you can enter a numerical value for the hit limit. 

In the Settings menu, the Set Hit Limit entry is displayed with a check mark if the hit limit is switched 
on. 

Menu Commands 

File 

Create New Database 

This opens a file browser dialogue for selecting a folder and entering a name for the new database. 
After closing the file browser dialogue by clicking on the OK button the new database is opened.  

A new database has a minimum attribute scheme with “Name” as its sole attribute. You may extend 
the scheme to fit your needs. To some extent the scheme can even be changed after the database 
has been filled. 

Change Database 

This opens a file browser dialogue to find and open a different database. 

Use Default Database 

This opens the default database.  

Export 

This muni item contains three sub-items which determine the extent of the data to be exported: 

• All Entries 

• Current Selection 

• Marked Entries 

After one of these entries has been selected, a dialog for navigating to a folder and entering a name 
for the new database. 

Import 

Opens a dialog for selecting the database to be imported. The entries of the other database will be 
merged to the entries already present. 

Edit  

The commands in this menu refer to a selected object. The same commands can be chosen in the 
context menu of the content lines. 
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Open 

Opens the object in the drawing tool, if it is a posture image, or in the assembly tool, if it is a sequence. 

Copy 

Copies the object into the Windows clipboard so you can paste it into your document. FlexMax objects 
can also be pasted into the drawing tool or the assembly tool. 

Delete 

Deletes the object. 

Settings 

Edit Attribute Scheme 

Opens the attribute scheme manager window. Cf. Editing the Attribute Scheme 

Set Hit Limit  

Opens a window in which you can configure the hit limit. Cf. Configure Hit Limit. 

Context Menu for the Header Line 

This menu opens when you right-click on the header line. It shows all available attributes, with a check 
mark on the visible ones. Select any attribute to reverse its visibility state. 

Context Menu for the Content Lines 

This menu opens when you right-click on a content line. It contains the same entries as the Edit menu. 

The Sample Database 
Using the database tool, you can create and use any number of FlexMax databases. FlexMax is 
installed with a Sample database, called “Database”, which contains a set of postures and sequences 
taken from Hatha-Yoga. 

The sample database is the current database when you start FlexMax for the first time. As soon as 
you use the Change Database or Create New Database command, you switch to a different 
database. You can return to the sample database at any time using the Use Default Database 
command. 

You can also use the sample database to store your own objects.  


